[uCsimm] General memory problem

From: Zach Shelby (zach.shelby@vtt.fi)
Date: Fri Dec 08 2000 - 06:20:20 EST


Actually, I'm having memory leak problems as well. I haven't noticed
it with the httpd (not using BOA...), but with one daemon I developed.

Basically it eats 1000B per loop for the program. It is reading data
from the serial port, parsing it with sscanf, then printing it to an
.HTML file using lots of fprintf. stringcpy is used as well. This
doesn't happen on my other 386 embedded linux machine (same code).
Buffers are permanent, not allocated/deallocated.

Any ideas?

- Zach Shelby

Friday, December 08, 2000, 10:30:45 AM, you scribbled:
EJ> Hi !

EJ> I'm using BOA (0.92q) with my uCsimm. Unfortunately I noticed that the
EJ> server memory usage increases with every http-access.
EJ> Is this a problem due to the MMU thing ?
EJ> Has anyone noticed the same problem or maybe bugfixes for the problem ?
EJ> Or is my configuration faulty ?

EJ> TIA

EJ> Joerg Epping

EJ> This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/

----------------------------------------------------------------------
   Zach Shelby - Researcher Zach.Shelby@vtt.fi
   VTT Elektronics Phone +358 8 551 2164 (Office)
   Kaitoväylä 1, PL 1100 Fax +358 8 551 2320
   90571 Oulu, Finland Mobile +358 40 7796297
----------------------------------------------------------------------
                    http://paula.oulu.fi/~zdshelby
       Home: Yliopistokatu 14-707 90570 Oulu, Finland

This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:39 EST