AW: [uCsimm] BOA - browser problem

From: Epping, Jörg (j.epping@benning.de)
Date: Thu Nov 30 2000 - 03:22:52 EST


        Hi, I had the same problem with my boa server (release 0.92q from
uclinux.net):
        Netscape 4.x -> no problem
        Internet Explorer 5.x -> always crashing

        I made a few(!) changes and it worked well:

        File "defines.h"
        #define SOCKETBUF_SIZE 500 // (was 4096)
        #define RESPONSEBUF_SIZE 500 // (was 1024)

        500 taken from BUFSIZ in stdio.h. Not sure why, but it works :-)

        and file "realloc.c"

        void *realloc (.....)
        {
                ...
                ret = (void *) malloc (t); // added the (void
*) cast to avoid m68k-compiler warnings
                ...

        Hope this will help you.

        Joerg

>
> Scott Cytacki wrote:
> >
> > Hi,
> >
> > I have boa running on a ucSimm. It runs cgi's just fine, but...
> >
> > It crashes and brings the whole ucLinux OS with it, when I use certain
> > browsers.
> >
> > Nice browsers:
> > 1. Netscape 4.61 for Linux
> > 2. iCab for the Mac
> >
> > Killers:
> > 1. IE 5 for the PC
> > 2. IE 4.5 for the Mac
> > 3. Netscape 4.61 for the Mac
> >
> > Don't know:
> > 1. Netscape 4.7 for PC
> >
> > Any ideas?
> >
> > Thanks,
> >
> > Scott
> > This message resent by the ucsimm@uclinux.com list server
> http://www.uClinux.com/
> This message resent by the ucsimm@uclinux.com list server
> http://www.uClinux.com/
> This message resent by the ucsimm@uclinux.com list server
> http://www.uClinux.com/
This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:39 EST