Re: [UCLINUX] Re: [uCsimm] LCD software question

From: Tom Walsh (tom@cyberiansoftware.com)
Date: Mon Jul 31 2000 - 17:47:07 EDT


When using the values in the tarball, or in your LCD setup (crt0_rom.S),
change the LYMAX value that I gave you from 239 to 240... For some
reason, I had read the DragonBall manual as requiring LYMAX to be Max
LCD scan lines - 1. This looks like another errate in the DragonBall
manual is needed by Motorola!

TomW

Tom Walsh wrote:
>
> David Jones wrote:
> >
> > Miles and Tom,
> > I have my Sharp LCD hooked up just like you guys described. I also changed
> > crt0_rom.S initializations for the LM32019. I also recompiled the kernal
> > and turned on console support. When I reboot, the kernal works but I get
> > no ouptput on the LCD. I have the LCD hooked up correctly and have verified,
> > the connections and voltages, and even currents! My inverter is working since
> > the LCD "lights" up blue. I have not checked the clks, data, and sync yet
> > with my scope, but I can if need be. I was thinking I must have missed a step
> > some where in the software setup??
>
> I just tried the LM32019 LCD with my new kernel, it works fine. I
> don't use the stock distro for my EZ328SIMM, I started with the Motorola
> ADS crt0*.S files and customized them to my use. You may have to make
> sure that the "#define LCD 1" is not commented out in your crt0_rom.S
> file, the stock uCsimm distro has this disabled.
>
> TomW
>
> --
> Tom Walsh - WN3L - Embedded Systems Consultant
> 'www.openhardware.net', 'www.cyberiansoftware.com'
> "Windows? No thanks, I have work to do..."

-- 
Tom Walsh - WN3L - Embedded Systems Consultant
'www.openhardware.net', 'www.cyberiansoftware.com'
"Windows? No thanks, I have work to do..."
This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:37 EST