[uCsimm] Re: I need a patch

From: Ryan McDonald (ryan@rt-control.com)
Date: Wed Jun 21 2000 - 08:00:38 EDT


Hello Julien:

>
> I know a new version of the CD exist and I am about to order it. Anyway,
> I would like to work now, so how can I get a patch ?
> I already tried to do this :
> - download uClinux-2.0.38.1pre7 from www.uclinux.org/pub/uClinux/
> - patch ...

You have to apply the patch to the bare linux-2.0.38 kernel (not the uClinux
2.0.38.0 kernel). Unpack the file /src/linux-2.0.38.tar.gz from the CD, and
then apply the pre7 patch.

> Another problem ...
> I have two linux environnement installed on my computer :
> - the SuSE 6.4 distribution with kernel 2.2.15 and libc6
> - the Suse 5.2 distribution with kernel 2.0.36 and libc5
>
> I am able to install uClinux developpement environnement correctly on
> the second system, but not on the first. When doing make (in
> /cdrom/RPM/libc6), here is what happen :
> >rpm -i uC-src-0.9.1-1.i386.rpm
> >error: failed dependencies:
> > libc.so.5 is needed by uC-src-0.9.1-1
 
To install on your SuSE 6.4 distribution, the makefile needs to be changed
to remove dependency checking.
All the lines with 'rpm -i' should have '--nodeps' added.
eg:
rpm -i --nodeps /cdrom/RPMS/libc6/m68k-coff-binutils-2.9.1-1.i386.rpm

Hope this helps,
-Ryan

-- 
Ryan McDonald
Rt-Control Inc -- A Lineo Company
Toronto, Ontario

This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:36 EST