Re: [uCsimm] Is it me, or are there really 2 copies of each dev in /dev?

From: Tom Walsh (tom@cyberiansoftware.com)
Date: Thu May 18 2000 - 01:54:35 EDT


Craig Pitches wrote:

> All:
>
> This has been my first day with a 'sort of working' uCsimm. It took
> awhile but I noticed that there are 2 entries for many if not all
> devices, name major and minor numbers are the same.
>
> I started from scratch and followed the basic steps in the manual to
> create the 'testing' development subtree. Looking at romdisk.map there
> are 2 sets of device files.
>
> Could I be doing something wrong?
>
> Thanks in advance,
>
> Craig

No, it appears that it *may* be a bug in the mkromfs distributed with
the RPMs. If you look at the /opt/uclinux/dev directory you will find
that there is a second directory named dev below that one. What I did
to correct the problem was to remove the nested ./dev/dev dir from ./dev.

I then went a step further, I deleted the link that buildenv makes to the
/opt/uclinux/dev dir and made a dir in its place, then I ran a script to
put devices into the that new dev dir. The script is at:
'ftp://ftp.cyberiansoftware.com/pub/EZ328SIMM/make_uclinux_devs.sh'.

Now I only have one '/dev/console' !!

Regards,

TomW

--
Tom Walsh - WN3L - Embedded Systems Consultant
'www.openhardware.net', 'www.cyberiansoftware.com'
"Windows? No thanks, I have work to do..."

This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:36 EST