Re: [uCsimm] LCD weirdness

From: Tom Walsh (tom@cyberiansoftware.com)
Date: Sun Mar 26 2000 - 21:41:55 EST


David Williams wrote:

> Another thought!
>
> Have a look at the contents of the memory being used as the display memory. Perhaps
> it does not contain what you think! If it is correct then you could trigger a CRO
> from the LFLM signal and look at the data imediately after this pulse to see what is
> being output by the LCD controller. If is OK then you are in trouble. If not OK then
> look at the display memory. If all electricals are OK then suspect a programming
> problem. Are chip selects set up correctly for memory being used for display memory?
> Is LCD controller DMA setup correctly? Is display memory simply being corrupted?
>
> Good Luck
> Dave.

    Thanks Dave, I will be trying to get a replacement for my broken scope tomorrow,
then I am going to take a serious look at the timings. This is no evidence of memory
corruption, I get a perfectly formed image, only inverted (black = old white, white =
old black), this has to some timing glitch. The scope should tell...

TomW

>
>
> David Williams wrote:
>
> > Hmm...
> >
> > Sounds like a timing problem to me. I would be looking at what happens
> > near LFLM transitions. I have used a custom LCD display interfaced to
> > 68EZ328 without problem.
> >
> > Dave.
> >
> > Tom Walsh wrote:
> >
> > > Has anyone experienced unexpected inverse video when using a 1/4
> > > (Sharp LM32019) or full vga (Epson EG9013) LCD displays? I have yet
> > > to put a 'scope onto the data lines, but it is related to the value of
> > > the first byte of the first line at the start of a frame. If this
> > > byte is set to 0xff, then the bitstream for that frame will be
> > > reversed, else if the the byte is 0x00, the bitstream is displayed as
> > > expected (normal video). No other byte value at any other location
> > > within the display memory has this effect, only the first byte pumped
> > > out at the beginning the Frame has this effect.
> > >
> > >
> > > Is this an "undocumented feature"?
> > >
> > >
> > > TomW
> > >
> > >
> > > --
> > > Tom Walsh - WN3L - Embedded Systems Consultant
> > > 'www.openhardware.net', 'www.cyberiansoftware.com'
> > > "Windows? No thanks, I have work to do..."
> > >
> > >
> >
> > This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/
>
> This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/

--
Tom Walsh - WN3L - Embedded Systems Consultant
'www.openhardware.net', 'www.cyberiansoftware.com'
"Windows? No thanks, I have work to do..."

This message resent by the ucsimm@uclinux.com list server http://www.uClinux.com/



This archive was generated by hypermail 2b30 : Sun Apr 07 2002 - 00:01:35 EST